about summary refs log tree commit diff
path: root/modules/system/documentation/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-09 11:19:50 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-09 11:19:50 -0700
commit23234600b9755ec6401872ea74e14b6fccde3fa3 (patch)
tree18241084c094866b3074ab546c4967093ef0839f /modules/system/documentation/default.nix
parentadd pcmanfm and easyeffects (diff)
downloadworld-23234600b9755ec6401872ea74e14b6fccde3fa3.tar.gz
install documentations (man)
Diffstat (limited to 'modules/system/documentation/default.nix')
-rw-r--r--modules/system/documentation/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/system/documentation/default.nix b/modules/system/documentation/default.nix
new file mode 100644
index 0000000..67f84ff
--- /dev/null
+++ b/modules/system/documentation/default.nix
@@ -0,0 +1,14 @@
+{ config, lib, pkgs, ... }: {
+  documentation = {
+    enable = true;
+    dev.enable = true;
+    info.enable = true;
+    man = {
+      enable = true;
+      generateCaches = true;
+    };
+    nixos.enable = true;
+  };
+
+  environment.systemPackages = with pkgs; [ man-pages man-pages-posix ];
+}