about summary refs log tree commit diff
path: root/modules/system/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-06 07:04:03 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-06 07:04:03 -0700
commit679497cf607e59cb4c62d80174228e776369751f (patch)
tree21e0f1e9436f1aabfe146d9aaec0dd36fbb06dd5 /modules/system/default.nix
parentrefactor configuration for AMD (diff)
downloadworld-679497cf607e59cb4c62d80174228e776369751f.tar.gz
refactor boot configuration to a module
We don't need the previous `hosts/common/system` configs anymore, as
everything has been moved out.

We keep some boot configuration for carmel in the host configuration for
now, but I need to check why I don't have similar settings for
tahoe (since I also need to unlock the host remotely).
Diffstat (limited to 'modules/system/default.nix')
-rw-r--r--modules/system/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/modules/system/default.nix b/modules/system/default.nix
index 620ad2e..c39d1d2 100644
--- a/modules/system/default.nix
+++ b/modules/system/default.nix
@@ -1 +1,5 @@
-{ ... }: { imports = [ ./console ./locale ./nix ./users ./security ./btrfs ]; }
+{ ... }:
+
+{
+  imports = [ ./boot ./console ./locale ./nix ./users ./security ./btrfs ];
+}