about summary refs log tree commit diff
path: root/modules/services/backup/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-04-29 17:11:31 -0700
committerFranck Cuny <franck@fcuny.net>2023-04-30 14:38:36 -0700
commit73490df322f7272068e752715b1747939d115b6e (patch)
tree54d0d0874254df74414f83a5a066e7e53407fce4 /modules/services/backup/default.nix
parentmodules/security: add ssh key for rsync.net to known hosts (diff)
downloadworld-73490df322f7272068e752715b1747939d115b6e.tar.gz
modules/backup: add a module for rsync
The NAS will rsync all the backups to rsync.net. This new module creates
a systemd unit and timer to do this task.
Diffstat (limited to 'modules/services/backup/default.nix')
-rw-r--r--modules/services/backup/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/modules/services/backup/default.nix b/modules/services/backup/default.nix
index 3481f3f..c9cce53 100644
--- a/modules/services/backup/default.nix
+++ b/modules/services/backup/default.nix
@@ -7,6 +7,8 @@ let
     + (writeText "excludes.txt" (concatStringsSep "\n" cfg.exclude));
 in
 {
+  imports = [ ./rsync.nix ];
+
   options.my.services.backup = with lib; {
     enable = mkEnableOption "Enable backups for this host";