about summary refs log tree commit diff
path: root/modules/services/avahi/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-10 18:27:57 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-10 18:27:57 -0700
commitca5e03a4e9c2346a42a3287f054eb96119da6b9c (patch)
tree4bb1444cf989436632a90c08be4885aa734e44ec /modules/services/avahi/default.nix
parentprofiles/git-server: fix path for the backup (diff)
downloadworld-ca5e03a4e9c2346a42a3287f054eb96119da6b9c.tar.gz
hosts/tahoe: move avahi configuration here
Diffstat (limited to 'modules/services/avahi/default.nix')
-rw-r--r--modules/services/avahi/default.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/modules/services/avahi/default.nix b/modules/services/avahi/default.nix
deleted file mode 100644
index 3a6eb58..0000000
--- a/modules/services/avahi/default.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{ config, pkgs, lib, ... }:
-let cfg = config.my.services.avahi;
-in
-{
-  options.my.services.avahi = with lib; {
-    enable = mkEnableOption "avahi service";
-    withReflector = mkEnableOption "enable reflector";
-    interfaces = mkOption {
-      type = types.nullOr (types.listOf types.str);
-      default = null;
-      description = "List of network interfaces that should be used by the {command}`avahi-daemon`.";
-    };
-  };
-
-  config = lib.mkIf cfg.enable {
-    services.avahi.enable = true;
-    # Important to resolve .local domains of printers, otherwise you get an error
-    # like  "Impossible to connect to XXX.local: Name or service not known"
-    services.avahi.nssmdns = true;
-
-    services.avahi.reflector = cfg.withReflector;
-    services.avahi.interfaces = cfg.interfaces;
-  };
-}