about summary refs log tree commit diff
path: root/lib/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-03 14:21:56 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-03 14:21:56 -0700
commite0a4b9f9caac97ae5f73b72f95c31ed9d719b7bd (patch)
tree6563fde50a8b56a32ca32fafb7b721824b5bec77 /lib/default.nix
parentremove mytools (diff)
downloadworld-e0a4b9f9caac97ae5f73b72f95c31ed9d719b7bd.tar.gz
rename `desktop` to `isDesktop`
The variable is used to define the kind of machine we're managing.
`isDesktop` is a bit more descriptive.

We import `devel` for all machines, and we fine tune which packages we
want to install based on the value of `isDesktop`.
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 89aff0a..aa55942 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -33,12 +33,12 @@
     { username
     , system
     , hostname
-    , desktop ? false
+    , isDesktop ? false
     }:
     inputs.home-manager.lib.homeManagerConfiguration {
       inherit username system;
       extraSpecialArgs = {
-        inherit system hostname desktop;
+        inherit system hostname isDesktop;
       };
       homeDirectory = "/home/${username}";
       configuration = ../users/${username};