about summary refs log tree commit diff
path: root/lib/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-09 09:51:17 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-09 09:51:17 -0700
commitc69e735bae3ab02d4645d1456f09cf0da5a1789a (patch)
treed28e530fc9f7f945bd5569c5ce1e11cf471425de /lib/default.nix
parentsmall fixes (diff)
downloadworld-c69e735bae3ab02d4645d1456f09cf0da5a1789a.tar.gz
remove `mkHome` from lib
home-manager configuration is used as a module, we don't have two
different ways to configure the host anymore.
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/lib/default.nix b/lib/default.nix
index d0a3d51..26cd954 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -33,37 +33,4 @@
         }
       ];
     };
-
-  mkHome =
-    { username
-    , system
-    , hostname
-    , isDesktop ? false
-    , isTrusted ? false
-    }:
-    inputs.home-manager.lib.homeManagerConfiguration {
-      inherit username system;
-      extraSpecialArgs = {
-        inherit system hostname isDesktop isTrusted;
-      };
-      homeDirectory = "/home/${username}";
-      configuration = ../users/${username};
-      extraModules = [
-        # Base configuration
-        {
-          nixpkgs = {
-            config.allowUnfree = true;
-            overlays = [
-              inputs.emacs-overlay.overlay
-              inputs.nur.overlay
-            ];
-          };
-          programs = {
-            home-manager.enable = true;
-            git.enable = true;
-          };
-          systemd.user.startServices = "sd-switch";
-        }
-      ];
-    };
 }