about summary refs log tree commit diff
path: root/hosts/tahoe/secrets/secrets.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-03-07 19:05:46 -0800
committerFranck Cuny <franck@fcuny.net>2023-03-10 18:20:16 -0800
commitb41aae5c88283d6efc03dd60253e4c0006460e9e (patch)
tree3df7946b1c821be7b6dbd1d66c111efdb05082cd /hosts/tahoe/secrets/secrets.nix
parenthosts/aptos: re-key all the secrets with age identities (diff)
downloadworld-b41aae5c88283d6efc03dd60253e4c0006460e9e.tar.gz
hosts/tahoe: re-key all the secrets with age identities
This is using the public keys from:
- my user on my laptop
- the root user on tahoe
- the backup key stored on the USB drive
Diffstat (limited to 'hosts/tahoe/secrets/secrets.nix')
-rw-r--r--hosts/tahoe/secrets/secrets.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/hosts/tahoe/secrets/secrets.nix b/hosts/tahoe/secrets/secrets.nix
index 2d23fda..8cdd5cf 100644
--- a/hosts/tahoe/secrets/secrets.nix
+++ b/hosts/tahoe/secrets/secrets.nix
@@ -1,9 +1,8 @@
 let
-  fcuny_aptos =
-    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIdlm/qoR/dnMjZhVSTtqFzkgN3Yf9eQ3pgKMiipg+dl";
-  tahoe =
-    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIEq1IQRvj2jofCHOO6M28w2SRdgtHU06NJvwAwv/b69F";
-  all = [ fcuny_aptos tahoe ];
+  root = "age1nxwgdy3p9fft0zsae440wyulknf5rk82s0wnxssrpxu4nezysa4qexcvpl";
+  fcuny = "age1keyvdhpspgqp4g5zjthdphau5q5qlt6fs0ex0wqnve66dmup9pzqn4sakj";
+  backup = "age1fh4960rdrk4d7m4c5lwd3trvw9ylk09dvucj2gd2udy7d5cz2a0svcqws6";
+  all = [ root fcuny backup ];
 in
 {
   "wireguard_privatekey.age".publicKeys = all;