about summary refs log tree commit diff
path: root/hosts/tahoe/home.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-06-09 09:17:44 -0700
committerFranck Cuny <franck@fcuny.net>2022-06-09 09:34:38 -0700
commit1d532775ec5ef37a14fc2b7f7cad364759a91fe8 (patch)
tree213e830b304dd57f8f3882440213ec1b2e84f700 /hosts/tahoe/home.nix
parentref(desktop): move all the modules for home-manager to host level (diff)
downloadworld-1d532775ec5ef37a14fc2b7f7cad364759a91fe8.tar.gz
ref(home): structure and add comments
Change-Id: I9abd49136df79a9ed040c9ec0e12eea30736c9ff
Reviewed-on: https://cl.fcuny.net/c/world/+/295
Reviewed-by: Franck Cuny <franck@fcuny.net>
Diffstat (limited to 'hosts/tahoe/home.nix')
-rw-r--r--hosts/tahoe/home.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/hosts/tahoe/home.nix b/hosts/tahoe/home.nix
index 2e56275..dc9c0aa 100644
--- a/hosts/tahoe/home.nix
+++ b/hosts/tahoe/home.nix
@@ -2,16 +2,25 @@
 
 {
   my.home = {
-    packages = { enable = true; };
+    # default packages I want on all hosts
+    packages.enable = true;
+
+    # terminal
     tmux.enable = true;
-    git.enable = true;
     ssh.enable = true;
     zsh.enable = true;
+
+    # software development
+    git.enable = true;
+
+    # multimedia
     beets = {
       enable = true;
       musicDirectory = "/data/fast/music";
     };
     flac.enable = true;
+
+    # web
     yt-dlp.enable = true;
   };
 }