about summary refs log tree commit diff
path: root/hosts/tahoe/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-27 13:02:39 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-27 13:02:39 -0800
commit2394e8924e32893f2489bf1f1677250198a807bd (patch)
tree8c6b47d9078447184f5592ec1e35ec679c6d8244 /hosts/tahoe/default.nix
parentdocs: backups! (diff)
downloadworld-2394e8924e32893f2489bf1f1677250198a807bd.tar.gz
hosts: add tahoe, the new NAS
Diffstat (limited to 'hosts/tahoe/default.nix')
-rw-r--r--hosts/tahoe/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/hosts/tahoe/default.nix b/hosts/tahoe/default.nix
new file mode 100644
index 0000000..22daf5d
--- /dev/null
+++ b/hosts/tahoe/default.nix
@@ -0,0 +1,41 @@
+{ config, pkgs, hostname, ... }:
+
+{
+  imports =
+    [ # Include the results of the hardware scan.
+      ./hardware-configuration.nix
+    ];
+
+  boot = {
+    initrd = {
+      luks.devices."system".allowDiscards = true;
+    };
+  };
+
+  # Use systemd-networkd for networking
+  systemd.network = {
+    enable = true;
+    networks = {
+      enp42s0 = {
+        matchConfig.Name = "enp42s0";
+        networkConfig = {
+          DHCP = "yes";
+        };
+        extraConfig = ''
+         [DHCPv4]
+         UseDNS=yes
+         UseDomains=yes
+        '';
+      };
+    };
+  };
+
+  # This value determines the NixOS release from which the default
+  # settings for stateful data, like file locations and database versions
+  # on your system were taken. It‘s perfectly fine and recommended to leave
+  # this value at the release version of the first install of this system.
+  # Before changing this value read the documentation for this option
+  # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+  system.stateVersion = "21.11"; # Did you read the comment?
+}
+