about summary refs log tree commit diff
path: root/hosts/profiles/nas.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-06 07:20:19 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-06 07:20:19 -0700
commite02aa9651bba1683877b29920d1d021aca8bcd13 (patch)
tree7c545b9f23f9f7fcddfeb21f1a753ba30fa713c5 /hosts/profiles/nas.nix
parentrefactor boot configuration to a module (diff)
downloadworld-e02aa9651bba1683877b29920d1d021aca8bcd13.tar.gz
refactor samba to a proper module
The list of public share is configurable too.
Diffstat (limited to 'hosts/profiles/nas.nix')
-rw-r--r--hosts/profiles/nas.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/hosts/profiles/nas.nix b/hosts/profiles/nas.nix
index 6585766..dcc73e2 100644
--- a/hosts/profiles/nas.nix
+++ b/hosts/profiles/nas.nix
@@ -2,7 +2,6 @@
   imports = [
     # other profiles
     ./server.nix
-    ../common/server/samba.nix
     ../common/server/prometheus.nix
     ../common/server/grafana.nix
     ../common/server/traefik.nix
@@ -20,6 +19,11 @@
     isSystemUser = true;
   };
 
+  my.services.samba = {
+    enable = true;
+    publicShares = [ "/data/fast/music" "/data/fast/videos" ];
+  };
+
   services.restic.backups = {
     media = {
       paths = [ "/data/fast/music" "/data/fast/photos" "/data/fast/videos" ];