about summary refs log tree commit diff
path: root/hosts/mba/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <fcuny@mba-fcuny.localdomain>2023-09-11 16:55:36 -0700
committerFranck Cuny <fcuny@mba-fcuny.localdomain>2023-09-11 16:55:36 -0700
commitc5b1c207532dd29b14d3f1a7b6b25a01a2e4824b (patch)
treea1af5028b5aa4c5944fbbee2af1418f6d704f433 /hosts/mba/default.nix
parentsome changes to GitHub action (diff)
downloadworld-c5b1c207532dd29b14d3f1a7b6b25a01a2e4824b.tar.gz
add configuration for the M2 macbook air
Diffstat (limited to 'hosts/mba/default.nix')
-rw-r--r--hosts/mba/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/hosts/mba/default.nix b/hosts/mba/default.nix
new file mode 100644
index 0000000..89e703e
--- /dev/null
+++ b/hosts/mba/default.nix
@@ -0,0 +1,23 @@
+{ pkgs, ... }:
+{
+  services.nix-daemon.enable = true;
+
+  programs.zsh.enable = true;
+
+  homebrew = {
+    enable = true;
+    onActivation.autoUpdate = true;
+
+    taps = [
+        "homebrew/cask-fonts"
+    ];
+
+    casks = [
+      "docker"
+      "emacs"
+      "font-source-code-pro"
+      "iterm2"
+      "wireshark"
+    ];
+  };
+}