about summary refs log tree commit diff
path: root/hosts/commons/system/users.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
commit8ed3dfc9ebc52a50c3e6d4623204847822944422 (patch)
tree5ecaf4eb3719f6d60e471775cd6de5da7cb78b46 /hosts/commons/system/users.nix
parentconfigs: move personal configuration with user (diff)
downloadworld-8ed3dfc9ebc52a50c3e6d4623204847822944422.tar.gz
move configurations and modules around
Sorry, this is a mess, hopefully the last one.
Diffstat (limited to 'hosts/commons/system/users.nix')
-rw-r--r--hosts/commons/system/users.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/hosts/commons/system/users.nix b/hosts/commons/system/users.nix
new file mode 100644
index 0000000..2b769c4
--- /dev/null
+++ b/hosts/commons/system/users.nix
@@ -0,0 +1,25 @@
+{ lib, pkgs, ... }:
+
+rec {
+  users.mutableUsers = false;
+
+  users.groups.fcuny = { gid = 1000; };
+  users.users.fcuny = {
+    isNormalUser = true;
+    uid = 1000;
+    group = "fcuny";
+    home = "/home/fcuny";
+    shell = pkgs.zsh;
+    extraGroups = [ "users" "wheel" ];
+    hashedPassword = "$6$i.z1brxtb44JAEco$fDD2Izl.zRR9vBCB2VBKPScChGw38EEl7QEiBTJ/EwgP3oSL0X3ZHq0PJ.RtqzBsWTPUjl4F3MKOBMhnaAPr6.";
+    openssh.authorizedKeys.keys = [
+      # aptops (laptop)
+      "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAACAQC1rWKrdSHxlAZnRv1F5jUsHgXSNmr1KzllWEn+JqA7p3zxmSEPBbfIUGxSzkFIQrSbKizJLdH6hGA8DcIm+e+ldQ2RYOdiYBxIkPm+aHB6dw7QGNbnSSdkr9gKThy65j0YOOcmuDExjqxfq6O/8AVstmPH36sUXEIks5F/+WiF+5ehzoJVFqClB1di6w1lml86d0ShrUacgM/ieFPe1vKrzW8ZOM+LaUoGWBTLla1y6UkIqnb7OinmgPu6QAzF6GA7tYJMoHkyV7Axzc2j1/VxVIrUrfY4b0k8lGAzi2GfByq+fXEHzePbaqi8Cy8Trn9eN/ls1WBMUQfSChQi3tM2Vx2BuiOpx/QkXsdgqwe7bTCijcQS7GoREL1qd8tR9sWWd4WMPUiC9kmzvyja5F39xHPgm0A5MtYY7GvQaUPbtBc6g8YuFLLnkqFVEKHSLFiGYP5jIDNvMd5rSSsBUrepCIzWdpprwnKxAjebw5Cyl5p/0MY2zppQRW7AZXehQa7Bv+OClbutEjBa+ioeUxBhezu2rB61XSenTbbUVB5DncD8ceD5AbL9aFz/Bcw6q0kAOGmR1G1MOLgxVHlqcnI5x0E1K2WMKWgQb+1BMek1p5+l3xWNDF4URhLqLupnP5CMrK9ifBOe/76zqyMVrA/mc6tNC58KHhME1IynC1zaLw== franck@fcuny.net"
+    ];
+  };
+
+  users.users.root = {
+    hashedPassword = null;
+    openssh.authorizedKeys.keys = users.users.fcuny.openssh.authorizedKeys.keys;
+  };
+}