about summary refs log tree commit diff
path: root/hosts/commons/system/software.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
commit8ed3dfc9ebc52a50c3e6d4623204847822944422 (patch)
tree5ecaf4eb3719f6d60e471775cd6de5da7cb78b46 /hosts/commons/system/software.nix
parentconfigs: move personal configuration with user (diff)
downloadworld-8ed3dfc9ebc52a50c3e6d4623204847822944422.tar.gz
move configurations and modules around
Sorry, this is a mess, hopefully the last one.
Diffstat (limited to 'hosts/commons/system/software.nix')
-rw-r--r--hosts/commons/system/software.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/hosts/commons/system/software.nix b/hosts/commons/system/software.nix
new file mode 100644
index 0000000..fa919ae
--- /dev/null
+++ b/hosts/commons/system/software.nix
@@ -0,0 +1,29 @@
+{pkgs, config, lib, ...}:
+
+{
+  environment.systemPackages = with pkgs; [
+    curl
+    dmidecode
+    git
+    htop
+    hwdata
+    iftop
+    iptraf-ng
+    lm_sensors
+    lsb-release
+    mg
+    mtr
+    openssl
+    parted
+    pciutils
+    rsync
+    strace
+    tcpdump
+    tmux
+    traceroute
+    unzip
+    usbutils
+    vim
+    wget
+  ];
+}