about summary refs log tree commit diff
path: root/hosts/commons/system/network.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
commit8ed3dfc9ebc52a50c3e6d4623204847822944422 (patch)
tree5ecaf4eb3719f6d60e471775cd6de5da7cb78b46 /hosts/commons/system/network.nix
parentconfigs: move personal configuration with user (diff)
downloadworld-8ed3dfc9ebc52a50c3e6d4623204847822944422.tar.gz
move configurations and modules around
Sorry, this is a mess, hopefully the last one.
Diffstat (limited to 'hosts/commons/system/network.nix')
-rw-r--r--hosts/commons/system/network.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/hosts/commons/system/network.nix b/hosts/commons/system/network.nix
new file mode 100644
index 0000000..df5aa27
--- /dev/null
+++ b/hosts/commons/system/network.nix
@@ -0,0 +1,19 @@
+{ config, pkgs, lib, hostname, ... }:
+
+{
+  networking = {
+    hostName = hostname;
+    useNetworkd = true;
+    wireless.enable = false;
+    useDHCP = false;
+  };
+
+  services.nscd.enable = false;
+  system.nssModules = lib.mkForce [ ];
+
+  # Use systemd-resolved
+  services.resolved = {
+    enable = true;
+    dnssec = "false";
+  };
+}