about summary refs log tree commit diff
path: root/hosts/commons/desktop/xserver.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
commit8ed3dfc9ebc52a50c3e6d4623204847822944422 (patch)
tree5ecaf4eb3719f6d60e471775cd6de5da7cb78b46 /hosts/commons/desktop/xserver.nix
parentconfigs: move personal configuration with user (diff)
downloadworld-8ed3dfc9ebc52a50c3e6d4623204847822944422.tar.gz
move configurations and modules around
Sorry, this is a mess, hopefully the last one.
Diffstat (limited to 'hosts/commons/desktop/xserver.nix')
-rw-r--r--hosts/commons/desktop/xserver.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/hosts/commons/desktop/xserver.nix b/hosts/commons/desktop/xserver.nix
new file mode 100644
index 0000000..7537863
--- /dev/null
+++ b/hosts/commons/desktop/xserver.nix
@@ -0,0 +1,23 @@
+{ config, pkgs, lib, ... }:
+
+{
+  services.xserver = {
+    enable = true;
+    layout = "us";
+    xkbOptions = "eurosign:e,ctrl:swapcaps";
+    libinput.enable = true;
+
+    desktopManager = {
+      xterm.enable = false;
+    };
+
+    displayManager = {
+      lightdm.enable = true;
+      defaultSession = "none+i3";
+    };
+
+    windowManager = {
+      i3.enable = true;
+    };
+  };
+}