about summary refs log tree commit diff
path: root/hosts/common/system/boot.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-18 09:29:26 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-18 09:30:39 -0800
commit5d3db43c0dec2971976c707415552715d9d16388 (patch)
tree4ae66abb9856356c5a6f45977f9ef2d48f7c4a7e /hosts/common/system/boot.nix
parentfonts: add more fonts for the system (diff)
downloadworld-5d3db43c0dec2971976c707415552715d9d16388.tar.gz
boot: reorganize and add comments
Most of the options for booting are common to all hosts.
Diffstat (limited to 'hosts/common/system/boot.nix')
-rw-r--r--hosts/common/system/boot.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/hosts/common/system/boot.nix b/hosts/common/system/boot.nix
index 974b072..053b81d 100644
--- a/hosts/common/system/boot.nix
+++ b/hosts/common/system/boot.nix
@@ -2,6 +2,14 @@
 
 {
   boot = {
+    loader = {
+      # Use the systemd-boot EFI boot loader.
+      systemd-boot.enable = true;
+       # Prohibits gaining root access by passing init=/bin/sh as a kernel parameter
+      boot.loader.systemd-boot.editor = false;
+      efi.canTouchEfiVariables = true;
+    };
+
     kernelPackages = pkgs.linuxPackages_latest;
     tmpOnTmpfs = true;
   };