about summary refs log tree commit diff
path: root/hosts/common/server/prometheus.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-03-11 19:32:23 -0800
committerFranck Cuny <franck@fcuny.net>2022-03-11 19:32:23 -0800
commit2ba4df7f2d27ef62551a5074de168ddc32902bb5 (patch)
treef541b115111d3fba089a949c2dddd7d41ddaa87e /hosts/common/server/prometheus.nix
parentrclone: synchronize restic repo to GCS (diff)
downloadworld-2ba4df7f2d27ef62551a5074de168ddc32902bb5.tar.gz
prometheus: scrap more endpoints
Diffstat (limited to 'hosts/common/server/prometheus.nix')
-rw-r--r--hosts/common/server/prometheus.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/hosts/common/server/prometheus.nix b/hosts/common/server/prometheus.nix
index 3c4ab94..00a7eba 100644
--- a/hosts/common/server/prometheus.nix
+++ b/hosts/common/server/prometheus.nix
@@ -46,6 +46,36 @@ in {
         relabel_configs = relabelConfigs;
       }
       {
+        job_name = "prometheus";
+        static_configs = [{ targets = [ "192.168.6.20:9090" ]; }];
+        relabel_configs = relabelConfigs;
+      }
+      {
+        job_name = "traefik";
+        static_configs = [{ targets = [ "192.168.6.20:8090" ]; }];
+        relabel_configs = relabelConfigs;
+      }
+      {
+        job_name = "dnsd";
+        static_configs = [{ targets = [ "192.168.6.1:8053" ]; }];
+        relabel_configs = relabelConfigs;
+      }
+      {
+        job_name = "dnsdd";
+        static_configs = [{ targets = [ "192.168.6.1:9060" ]; }];
+        relabel_configs = relabelConfigs;
+      }
+      {
+        job_name = "dhcpd";
+        static_configs = [{ targets = [ "192.168.6.1:8067" ]; }];
+        relabel_configs = relabelConfigs;
+      }
+      {
+        job_name = "netd";
+        static_configs = [{ targets = [ "192.168.6.1:8055" ]; }];
+        relabel_configs = relabelConfigs;
+      }
+      {
         job_name = "unifi-poller";
         static_configs = [{ targets = [ "192.168.6.20:9130" ]; }];
         relabel_configs = relabelConfigs;