about summary refs log tree commit diff
path: root/hosts/common/desktop/xserver.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-12 13:53:12 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-12 13:54:53 -0800
commit8c7ce797eb2a1c5b8b3c602ecd3300cd23e8b46c (patch)
tree445cbdba282c01659a1e9a14583a1e7283106315 /hosts/common/desktop/xserver.nix
parenthosts: import common modules (diff)
downloadworld-8c7ce797eb2a1c5b8b3c602ecd3300cd23e8b46c.tar.gz
hosts: rename commons to common
Diffstat (limited to 'hosts/common/desktop/xserver.nix')
-rw-r--r--hosts/common/desktop/xserver.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/hosts/common/desktop/xserver.nix b/hosts/common/desktop/xserver.nix
new file mode 100644
index 0000000..7537863
--- /dev/null
+++ b/hosts/common/desktop/xserver.nix
@@ -0,0 +1,23 @@
+{ config, pkgs, lib, ... }:
+
+{
+  services.xserver = {
+    enable = true;
+    layout = "us";
+    xkbOptions = "eurosign:e,ctrl:swapcaps";
+    libinput.enable = true;
+
+    desktopManager = {
+      xterm.enable = false;
+    };
+
+    displayManager = {
+      lightdm.enable = true;
+      defaultSession = "none+i3";
+    };
+
+    windowManager = {
+      i3.enable = true;
+    };
+  };
+}