about summary refs log tree commit diff
path: root/hosts/carmel/hardware-configuration.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-07 18:05:58 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-07 18:05:58 -0800
commitbd7d3e28ad6dc59f84ad5b6eb8101832d2d6eda3 (patch)
treed4b73c173a3b8fa0de89c5cf66ac0db4adc6a6c6 /hosts/carmel/hardware-configuration.nix
parentdoc: how to install the system (diff)
downloadworld-bd7d3e28ad6dc59f84ad5b6eb8101832d2d6eda3.tar.gz
carmel: initial host configuration
Initial configuration for the desktop (carmel).
Diffstat (limited to 'hosts/carmel/hardware-configuration.nix')
-rw-r--r--hosts/carmel/hardware-configuration.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/hosts/carmel/hardware-configuration.nix b/hosts/carmel/hardware-configuration.nix
new file mode 100644
index 0000000..17aba16
--- /dev/null
+++ b/hosts/carmel/hardware-configuration.nix
@@ -0,0 +1,48 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports =
+    [ (modulesPath + "/installer/scan/not-detected.nix")
+    ];
+
+  boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-amd" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    { device = "/dev/disk/by-uuid/7d4e07d8-1104-4ab8-8ead-8ca28da2d344";
+      fsType = "btrfs";
+      options = [ "subvol=nixos" ];
+    };
+
+  boot.initrd.luks.devices."system".device = "/dev/disk/by-uuid/dd1b3673-ece0-49f8-bf71-8cc4e1a06634";
+
+  fileSystems."/home" =
+    { device = "/dev/disk/by-uuid/7d4e07d8-1104-4ab8-8ead-8ca28da2d344";
+      fsType = "btrfs";
+      options = [ "subvol=home" ];
+    };
+
+  fileSystems."/.snapshots" =
+    { device = "/dev/disk/by-uuid/7d4e07d8-1104-4ab8-8ead-8ca28da2d344";
+      fsType = "btrfs";
+      options = [ "subvol=snapshots" ];
+    };
+
+  fileSystems."/boot" =
+    { device = "/dev/disk/by-uuid/7430-1C58";
+      fsType = "vfat";
+    };
+
+  swapDevices =
+    [ { device = "/dev/disk/by-uuid/ebcb04f3-4227-4ec3-af52-bd775ef38027"; }
+    ];
+
+  hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+  # high-resolution display
+  hardware.video.hidpi.enable = lib.mkDefault true;
+}