about summary refs log tree commit diff
path: root/hosts/carmel/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-10 18:13:41 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-10 18:13:41 -0800
commitcb788261448f0cc1aff6bf6505f5b6bcd7a17531 (patch)
tree5faa1b442d33ffaefaf3654843f0408c9bfb7210 /hosts/carmel/default.nix
parenthome-manager: split the configuration (diff)
downloadworld-cb788261448f0cc1aff6bf6505f5b6bcd7a17531.tar.gz
nix: fix a bunch of stuff
Diffstat (limited to 'hosts/carmel/default.nix')
-rw-r--r--hosts/carmel/default.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/hosts/carmel/default.nix b/hosts/carmel/default.nix
new file mode 100644
index 0000000..19c88c0
--- /dev/null
+++ b/hosts/carmel/default.nix
@@ -0,0 +1,43 @@
+{ config, pkgs, ... }:
+
+{
+  imports =
+    [ # Include the results of the hardware scan.
+      ./hardware-configuration.nix
+      ../../modules/desktop
+    ];
+
+  nix = {
+    package = pkgs.nixUnstable;
+  };
+
+  # Use the systemd-boot EFI boot loader.
+  boot.loader.systemd-boot.enable = true;
+  boot.loader.efi.canTouchEfiVariables = true;
+
+  time.timeZone = "America/Los_Angeles";
+
+  networking.hostName = "carmel"; # Define your hostname.
+
+  networking.wireless.enable = false;
+  networking.interfaces.enp9s0.useDHCP = true;
+  networking.interfaces.wlp8s0.useDHCP = true;
+  # TODO: If set to false, systemd hangs on boot, unclear why.
+
+  services.xserver.dpi = 168;
+
+  # Use systemd-resolved
+  services.resolved = {
+    enable = true;
+    dnssec = "false";
+  };
+
+  # This value determines the NixOS release from which the default
+  # settings for stateful data, like file locations and database versions
+  # on your system were taken. It‘s perfectly fine and recommended to leave
+  # this value at the release version of the first install of this system.
+  # Before changing this value read the documentation for this option
+  # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+  system.stateVersion = "21.11"; # Did you read the comment?
+}
+