about summary refs log tree commit diff
path: root/hosts/aptos/hardware-configuration.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-05 20:23:51 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-05 20:23:51 -0700
commit2c078669e3b526f3c4ea9d383adddedf30535946 (patch)
treea01656329b8d44012b3799eb573b902a62047091 /hosts/aptos/hardware-configuration.nix
parentrefactor modules for btrfs, ssd, and fwupd (diff)
downloadworld-2c078669e3b526f3c4ea9d383adddedf30535946.tar.gz
refactor intel related configuration
Diffstat (limited to 'hosts/aptos/hardware-configuration.nix')
-rw-r--r--hosts/aptos/hardware-configuration.nix53
1 files changed, 26 insertions, 27 deletions
diff --git a/hosts/aptos/hardware-configuration.nix b/hosts/aptos/hardware-configuration.nix
index 8cdf86f..085db9f 100644
--- a/hosts/aptos/hardware-configuration.nix
+++ b/hosts/aptos/hardware-configuration.nix
@@ -4,43 +4,42 @@
 { config, lib, pkgs, modulesPath, ... }:
 
 {
-  imports =
-    [ (modulesPath + "/installer/scan/not-detected.nix")
-    ];
+  imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
 
-  boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
+  boot.initrd.availableKernelModules =
+    [ "xhci_pci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
   boot.initrd.kernelModules = [ ];
   boot.extraModulePackages = [ ];
 
-  fileSystems."/" =
-    { device = "/dev/disk/by-uuid/292e07ac-4199-4a97-94a6-bd2fd2a9cf6a";
-      fsType = "btrfs";
-      options = [ "subvol=nixos" ];
-    };
+  fileSystems."/" = {
+    device = "/dev/disk/by-uuid/292e07ac-4199-4a97-94a6-bd2fd2a9cf6a";
+    fsType = "btrfs";
+    options = [ "subvol=nixos" ];
+  };
 
-  boot.initrd.luks.devices."system".device = "/dev/disk/by-uuid/c83a8db7-4215-4864-8a46-b8ca839d8c05";
+  boot.initrd.luks.devices."system".device =
+    "/dev/disk/by-uuid/c83a8db7-4215-4864-8a46-b8ca839d8c05";
 
-  fileSystems."/home" =
-    { device = "/dev/disk/by-uuid/292e07ac-4199-4a97-94a6-bd2fd2a9cf6a";
-      fsType = "btrfs";
-      options = [ "subvol=home" ];
-    };
+  fileSystems."/home" = {
+    device = "/dev/disk/by-uuid/292e07ac-4199-4a97-94a6-bd2fd2a9cf6a";
+    fsType = "btrfs";
+    options = [ "subvol=home" ];
+  };
 
-  fileSystems."/.snapshots" =
-    { device = "/dev/disk/by-uuid/292e07ac-4199-4a97-94a6-bd2fd2a9cf6a";
-      fsType = "btrfs";
-      options = [ "subvol=snapshots" ];
-    };
+  fileSystems."/.snapshots" = {
+    device = "/dev/disk/by-uuid/292e07ac-4199-4a97-94a6-bd2fd2a9cf6a";
+    fsType = "btrfs";
+    options = [ "subvol=snapshots" ];
+  };
 
-  fileSystems."/boot" =
-    { device = "/dev/disk/by-uuid/42D9-6EA8";
-      fsType = "vfat";
-    };
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-uuid/42D9-6EA8";
+    fsType = "vfat";
+  };
 
   swapDevices =
-    [ { device = "/dev/disk/by-uuid/24041034-ff39-44bf-a04c-8fd8318b554d"; }
-    ];
+    [{ device = "/dev/disk/by-uuid/24041034-ff39-44bf-a04c-8fd8318b554d"; }];
 
+  my.hardware.intel.enable = true;
   powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
-  hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
 }