about summary refs log tree commit diff
path: root/hosts/aptos/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-20 18:48:19 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-21 08:43:34 -0800
commitfdf325c76623bf408d4e1ea8181aa678d3aea0f9 (patch)
tree1ec87e4463a1b5c30bb3ffa1f7006acc566fb73c /hosts/aptos/default.nix
parentdocs: more update (diff)
downloadworld-fdf325c76623bf408d4e1ea8181aa678d3aea0f9.tar.gz
hosts: add aptos
aptos is my laptop (dell xps 13'). This adds the initial configuration
for it.
Diffstat (limited to 'hosts/aptos/default.nix')
-rw-r--r--hosts/aptos/default.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/hosts/aptos/default.nix b/hosts/aptos/default.nix
new file mode 100644
index 0000000..7501853
--- /dev/null
+++ b/hosts/aptos/default.nix
@@ -0,0 +1,44 @@
+{ config, pkgs, hostname, ... }:
+
+{
+  imports =
+    [ # Include the results of the hardware scan.
+      ./hardware-configuration.nix
+      ../common/desktop
+    ];
+
+  boot = {
+    initrd = {
+      luks.devices."system".allowDiscards = true;
+    };
+  };
+
+  # Use systemd-networkd for networking
+  systemd.network = {
+    enable = true;
+    networks = {
+      wlp0s20f3 = {
+        matchConfig.Name = "wlp0s20f3";
+        networkConfig = {
+          DHCP = "yes";
+        };
+        extraConfig = ''
+         [DHCPv4]
+         UseDNS=yes
+         UseDomains=yes
+        '';
+      };
+    };
+  };
+
+  networking.wireless.enable = true;
+
+  # This value determines the NixOS release from which the default
+  # settings for stateful data, like file locations and database versions
+  # on your system were taken. It‘s perfectly fine and recommended to leave
+  # this value at the release version of the first install of this system.
+  # Before changing this value read the documentation for this option
+  # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+  system.stateVersion = "21.11"; # Did you read the comment?
+}
+