about summary refs log tree commit diff
path: root/hosts/aptos/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-12 14:04:17 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-12 14:04:17 -0700
commit4f33e1dc6fe13eab7655ffd58f713c457496d791 (patch)
tree77a619a5a99162721471058afc4362f4e784c240 /hosts/aptos/default.nix
parenthosts: move around backup configuration (diff)
downloadworld-4f33e1dc6fe13eab7655ffd58f713c457496d791.tar.gz
hosts/aptos: move network configuration to default.nix
Diffstat (limited to 'hosts/aptos/default.nix')
-rw-r--r--hosts/aptos/default.nix21
1 files changed, 19 insertions, 2 deletions
diff --git a/hosts/aptos/default.nix b/hosts/aptos/default.nix
index b2236f5..6b7f695 100644
--- a/hosts/aptos/default.nix
+++ b/hosts/aptos/default.nix
@@ -1,4 +1,4 @@
-{ self, config, ... }:
+{ self, config, lib, ... }:
 let
   secrets = config.age.secrets;
   ssh-key-path = secrets."restic/ssh-key".path;
@@ -6,7 +6,6 @@ in
 {
   imports = [
     ./hardware.nix
-    ./networking.nix
     "${self}/profiles/btrfs.nix"
     "${self}/profiles/documentation.nix"
     "${self}/profiles/laptop.nix"
@@ -14,6 +13,24 @@ in
     "${self}/profiles/hardware/xps9300.nix"
   ];
 
+  # Use systemd-networkd for networking
+  systemd.network.enable = true;
+  systemd.network.networks.wlan0 = {
+    matchConfig.Name = "wlan0";
+    networkConfig.DHCP = "yes";
+    dhcpV4Config = {
+      UseDNS = "yes";
+      UseDomains = "yes";
+    };
+  };
+
+  networking.useNetworkd = true;
+  networking.useDHCP = false;
+  networking.private-wireguard.enable = true;
+
+  services.nscd.enable = false;
+  system.nssModules = lib.mkForce [ ];
+
   my.services.backup = {
     enable = true;
     repository = "sftp:192.168.6.40:/${config.networking.hostName}";