about summary refs log tree commit diff
path: root/hosts/aptos/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-09-22 18:05:34 -0700
committerFranck Cuny <franck@fcuny.net>2022-09-22 18:05:34 -0700
commit4f1513dfa4fc22240ab7dcbe1c60c14f827645a7 (patch)
treeb81a45ae768dc2620d54e3b6a41b2c485d1f6aac /hosts/aptos/default.nix
parentref(flake): move all the checks to external module (diff)
downloadworld-4f1513dfa4fc22240ab7dcbe1c60c14f827645a7.tar.gz
ref(home-manager): don't use home-manager when building the host
When rebuilding the host (through `nixos-rebuild switch --flake`) I
don't want to rebuild also my home-manager configuration. I want these
to be two different steps.

I rebuild the home-manager configuration more frequently and it's a
waste of time and CPU to rebuild the world every time.

This is a pretty large refactoring:
- move checks back into the flake: if I modify a check, the
  configuration for `pre-commits` is not regenerated, as the file with the
  checks is not monitored with `direnv` (I could probably configure it for
  it, but not now)
- remove `home.nix` from the host level configuration
- introduce a `mkHomeManagerConfiguration` function to manage the
  different user@host
- fix a warning with the rust overlay
Diffstat (limited to 'hosts/aptos/default.nix')
-rw-r--r--hosts/aptos/default.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/hosts/aptos/default.nix b/hosts/aptos/default.nix
index 7c51741..f92ce07 100644
--- a/hosts/aptos/default.nix
+++ b/hosts/aptos/default.nix
@@ -1,14 +1,7 @@
 { config, pkgs, hostname, ... }:
 
 {
-  imports = [
-    # Include the results of the hardware scan.
-    ./hardware.nix
-    ./sound.nix
-    ./networking.nix
-    ./home.nix
-    ./services.nix
-  ];
+  imports = [ ./hardware.nix ./sound.nix ./networking.nix ./services.nix ];
 
   # Allow setting GTK configuration using home-manager
   programs.dconf.enable = true;