about summary refs log tree commit diff
path: root/home/zsh.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-03-04 15:02:31 -0800
committerFranck Cuny <franck@fcuny.net>2024-03-04 15:02:31 -0800
commite2f467882f9fd67805b69e5dff6c1652d4c47629 (patch)
tree500206b90fe6d81b44a8a9cbe78d2fe5becafd1b /home/zsh.nix
parentcreate profiles for home-manager (diff)
downloadworld-e2f467882f9fd67805b69e5dff6c1652d4c47629.tar.gz
move all home-manager settings under the profiles
Diffstat (limited to 'home/zsh.nix')
-rw-r--r--home/zsh.nix46
1 files changed, 0 insertions, 46 deletions
diff --git a/home/zsh.nix b/home/zsh.nix
deleted file mode 100644
index e704870..0000000
--- a/home/zsh.nix
+++ /dev/null
@@ -1,46 +0,0 @@
-{ config, pkgs, ... }:
-{
-  home.packages = with pkgs; [ zsh-completions ];
-
-  programs.zsh = {
-    enable = true;
-    dotDir = ".config/zsh";
-
-    defaultKeymap = "emacs";
-    enableCompletion = true;
-    enableAutosuggestions = true;
-
-    history = {
-      size = 500000;
-      save = 500000;
-      extended = true;
-      ignoreSpace = true;
-      ignoreDups = true;
-      share = true;
-      # see
-      # https://github.com/nix-community/home-manager/blob/32a7da69dc53c9eb5ad0675eb7fdc58f7fe35272/modules/programs/zsh.nix#L537
-      path = "${config.xdg.dataHome}/zsh/zsh_history";
-    };
-
-    localVariables = {
-      # Print timing statistics for everything which takes longer than
-      # 5 seconds of user + system time.
-      REPORTTIME = 5;
-    };
-
-    shellAliases = {
-      ll = "ls -l --color=auto";
-      lt = "ls -ltrh --color=auto";
-      la = "ls -ltrha --color=auto";
-      pkgsearch = "nix search nixpkgs";
-      flup = "nix flake update --commit-lock-file";
-      emacsrescue = "pkill -SIGUSR2 -i emacs"; # then `M-x toggle-debug-on-quit`
-    };
-
-    oh-my-zsh = {
-      enable = true;
-      plugins = [ "git" ];
-      theme = "robbyrussell";
-    };
-  };
-}