about summary refs log tree commit diff
path: root/home/transmission-remote/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-09 11:31:39 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-09 11:31:39 -0700
commit5c929290c03bcfbc243062157098458a77c2817e (patch)
tree796518fc50b7db940e47127ea67453fcc1a69779 /home/transmission-remote/default.nix
parentinstall documentations (man) (diff)
downloadworld-5c929290c03bcfbc243062157098458a77c2817e.tar.gz
add a few more packages for home/
Diffstat (limited to 'home/transmission-remote/default.nix')
-rw-r--r--home/transmission-remote/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/home/transmission-remote/default.nix b/home/transmission-remote/default.nix
new file mode 100644
index 0000000..29c070b
--- /dev/null
+++ b/home/transmission-remote/default.nix
@@ -0,0 +1,10 @@
+{ lib, config, pkgs, ... }:
+let cfg = config.my.home.transmission-remote;
+in {
+  options.my.home.transmission-remote = with lib; {
+    enable = mkEnableOption "transmission-remote configuration";
+  };
+
+  config.home.packages = with pkgs;
+    lib.mkIf cfg.enable ([ transmission-remote-gtk ]);
+}