about summary refs log tree commit diff
path: root/home/tmux.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-12-14 06:19:50 -0800
committerFranck Cuny <franck@fcuny.net>2023-12-14 06:19:59 -0800
commit94142ef5780de4a049436de08b8d7e0cd3d04245 (patch)
tree7e55f6a70bba904934a088d43f464bccbb78bdb3 /home/tmux.nix
parentbuild(deps): bump cachix/install-nix-action from 23 to 24 (diff)
downloadworld-94142ef5780de4a049436de08b8d7e0cd3d04245.tar.gz
simplify the layout
Diffstat (limited to 'home/tmux.nix')
-rw-r--r--home/tmux.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/home/tmux.nix b/home/tmux.nix
new file mode 100644
index 0000000..22f8683
--- /dev/null
+++ b/home/tmux.nix
@@ -0,0 +1,20 @@
+{ ... }:
+{
+  programs.tmux = {
+    enable = true;
+
+    terminal = "xterm-256color";
+    escapeTime = 0;
+    aggressiveResize = true;
+    baseIndex = 1;
+    shortcut = "z";
+    clock24 = true;
+    historyLimit = 50000; # Bigger buffer
+
+    extraConfig = ''
+      setw -g mouse on
+
+      set-option -g renumber-windows on
+    '';
+  };
+}