about summary refs log tree commit diff
path: root/home/shell/zsh/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
commit43da9edb4598eef509c481ae0b305384418c45de (patch)
treea0ad614c90102757143e026e4fe1806431a3dbf4 /home/shell/zsh/default.nix
parentprofiles/default: users are immutable (diff)
downloadworld-43da9edb4598eef509c481ae0b305384418c45de.tar.gz
home/profiles: move (almost) all modules to profiles
This is a major refactor, similar to what was done for the hosts, but in
a single commit.
Diffstat (limited to 'home/shell/zsh/default.nix')
-rw-r--r--home/shell/zsh/default.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/home/shell/zsh/default.nix b/home/shell/zsh/default.nix
deleted file mode 100644
index 3734fc3..0000000
--- a/home/shell/zsh/default.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-{ config, pkgs, lib, ... }:
-let
-  cfg = config.my.home.shell;
-  aliases = config.my.home.shell.aliases;
-in
-{
-  config = lib.mkIf (cfg.name == "zsh") {
-    home.packages = with pkgs; [ zsh-completions ];
-
-    programs.zsh = {
-      enable = true;
-      dotDir = ".config/zsh";
-
-      enableCompletion = true;
-      enableAutosuggestions = true;
-
-      history = {
-        size = 500000;
-        save = 500000;
-        extended = false;
-        ignoreSpace = true;
-        ignoreDups = true;
-        share = false;
-        # see
-        # https://github.com/nix-community/home-manager/blob/32a7da69dc53c9eb5ad0675eb7fdc58f7fe35272/modules/programs/zsh.nix#L537
-        path = ".local/share/zsh/zsh_history";
-      };
-
-      localVariables = {
-        # Print timing statistics for everything which takes longer than 5 seconds of
-        # user + system time.
-        REPORTTIME = 5;
-      };
-
-      shellAliases = aliases;
-
-      defaultKeymap = "emacs";
-
-      initExtra = lib.concatMapStrings builtins.readFile [
-        ./completion-style.zsh
-        ./options.zsh
-        ./prompt.zsh
-        ./tmux.zsh
-        ./new-go-project.zsh
-      ];
-    };
-  };
-}