about summary refs log tree commit diff
path: root/home/shell/fish/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-06-20 13:45:50 -0700
committerFranck Cuny <franck@fcuny.net>2022-06-20 14:41:06 -0700
commit47692795b39aa4463487be3202f62ae900797d24 (patch)
treed36b0adaf6440526e0b7edff5a36a13ea3c3ff96 /home/shell/fish/default.nix
parentref(home/shell): switch default shell to fish (diff)
downloadworld-47692795b39aa4463487be3202f62ae900797d24.tar.gz
feat(home/shell): manage fish's functions directory
Change-Id: I03a35a211c7563e65770b39b140099291efafab9
Reviewed-on: https://cl.fcuny.net/c/world/+/458
Reviewed-by: Franck Cuny <franck@fcuny.net>
Tested-by: CI
Diffstat (limited to 'home/shell/fish/default.nix')
-rw-r--r--home/shell/fish/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/home/shell/fish/default.nix b/home/shell/fish/default.nix
index c81f188..d000cd9 100644
--- a/home/shell/fish/default.nix
+++ b/home/shell/fish/default.nix
@@ -27,5 +27,9 @@ in
         end
       '';
     };
+    xdg.configFile."fish/functions" = {
+      source = ./functions;
+      recursive = true;
+    };
   };
 }