about summary refs log tree commit diff
path: root/home/shell/fish/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-05 19:41:58 -0700
commit43da9edb4598eef509c481ae0b305384418c45de (patch)
treea0ad614c90102757143e026e4fe1806431a3dbf4 /home/shell/fish/default.nix
parentprofiles/default: users are immutable (diff)
downloadworld-43da9edb4598eef509c481ae0b305384418c45de.tar.gz
home/profiles: move (almost) all modules to profiles
This is a major refactor, similar to what was done for the hosts, but in
a single commit.
Diffstat (limited to 'home/shell/fish/default.nix')
-rw-r--r--home/shell/fish/default.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/home/shell/fish/default.nix b/home/shell/fish/default.nix
deleted file mode 100644
index f3e41d9..0000000
--- a/home/shell/fish/default.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-{ config, lib, pkgs, ... }:
-let
-  cfg = config.my.home.shell;
-  aliases = config.my.home.shell.aliases;
-in
-{
-  config = lib.mkIf (cfg.name == "fish") {
-    programs.fish = {
-      enable = true;
-      shellAliases = aliases;
-      interactiveShellInit = builtins.readFile ./interactive.fish;
-      loginShellInit = builtins.readFile ./login.fish;
-    };
-
-    xdg.configFile."fish/functions" = {
-      source = ./functions;
-      recursive = true;
-    };
-  };
-}