about summary refs log tree commit diff
path: root/home/profiles/zsh.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-16 20:09:27 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-16 20:09:27 -0700
commit354afc1754f0616cd086b1a6f607022155a1f9e3 (patch)
treed79cde08506a4297e749828d8f6662b88f69b5cd /home/profiles/zsh.nix
parenthome/ssh: add rsync.net to the match block (diff)
downloadworld-354afc1754f0616cd086b1a6f607022155a1f9e3.tar.gz
profiles/workstation: stop using dark mode + prezto
Diffstat (limited to 'home/profiles/zsh.nix')
-rw-r--r--home/profiles/zsh.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/home/profiles/zsh.nix b/home/profiles/zsh.nix
new file mode 100644
index 0000000..3da6baa
--- /dev/null
+++ b/home/profiles/zsh.nix
@@ -0,0 +1,51 @@
+{ config, pkgs, lib, ... }:
+{
+  home.packages = with pkgs; [ zsh-completions ];
+
+  programs.zsh = {
+    enable = true;
+    dotDir = ".config/zsh";
+
+    defaultKeymap = "emacs";
+    enableCompletion = true;
+    enableAutosuggestions = true;
+
+    history = {
+      size = 500000;
+      save = 500000;
+      extended = true;
+      ignoreSpace = true;
+      ignoreDups = true;
+      share = true;
+      # see
+      # https://github.com/nix-community/home-manager/blob/32a7da69dc53c9eb5ad0675eb7fdc58f7fe35272/modules/programs/zsh.nix#L537
+      path = "${config.xdg.dataHome}/zsh/zsh_history";
+    };
+
+    localVariables = {
+      # Print timing statistics for everything which takes longer than 5 seconds of
+      # user + system time.
+      REPORTTIME = 5;
+    };
+
+    shellAliases = {
+      ll = "ls -l --color=auto";
+      lt = "ls -ltrh --color=auto";
+      la = "ls -ltrha --color=auto";
+      pkgsearch = "nix search nixpkgs";
+      hms = "home-manager switch --flake .";
+      nr = "sudo nixos-rebuild switch --flake .";
+      flup = "nix flake update --commit-lock-file";
+      dhcp-leasese = "xdg-open http://192.168.6.1:8067/";
+    };
+
+    prezto = {
+      enable = true;
+      prompt = { theme = "pure"; };
+      pmodules = [
+        "prompt"
+        "git"
+      ];
+    };
+  };
+}