about summary refs log tree commit diff
path: root/home/profiles/git.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-09-14 17:18:09 -0700
committerFranck Cuny <franck@fcuny.net>2023-09-14 17:36:58 -0700
commit17a8f86782b773c77880e34b6a02e53def4015e8 (patch)
treeee611470d040b90331865b7e519b7e737ea70c29 /home/profiles/git.nix
parentbuild(deps): bump cachix/install-nix-action from 22 to 23 (#2) (diff)
downloadworld-17a8f86782b773c77880e34b6a02e53def4015e8.tar.gz
more configuration for darwin
Diffstat (limited to 'home/profiles/git.nix')
-rw-r--r--home/profiles/git.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/home/profiles/git.nix b/home/profiles/git.nix
index cf90da6..6846a08 100644
--- a/home/profiles/git.nix
+++ b/home/profiles/git.nix
@@ -1,7 +1,7 @@
-{ self, lib, pkgs, config, ... }:
+{ lib, pkgs, config, ... }:
 let
   sshPub = builtins.fromTOML (
-    builtins.readFile "${self}/configs/ssh-pubkeys.toml"
+    builtins.readFile ../../configs/ssh-pubkeys.toml
   );
 in
 {
@@ -14,7 +14,7 @@ in
 
     signing = {
       key = "key::${sshPub.ykey-laptop}";
-      signByDefault = true;
+      signByDefault = false;
     };
 
     extraConfig = {
@@ -68,7 +68,6 @@ in
 '';
 
   home.packages = with pkgs; [
-    tools.git-blame-stats
     gitAndTools.pre-commit
   ];
 }