about summary refs log tree commit diff
path: root/home/profiles/git.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-09-14 17:57:26 -0700
committerFranck Cuny <franck@fcuny.net>2023-09-14 19:13:40 -0700
commit0eb76d0ae036549203e117bf187450ee495a8953 (patch)
treee727cfe3381d9391f8da3902fadf382601e0203e /home/profiles/git.nix
parentflake.lock: Update (diff)
downloadworld-0eb76d0ae036549203e117bf187450ee495a8953.tar.gz
add ssh key from 1passowrd and sign commits
Diffstat (limited to 'home/profiles/git.nix')
-rw-r--r--home/profiles/git.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/home/profiles/git.nix b/home/profiles/git.nix
index 6846a08..d559150 100644
--- a/home/profiles/git.nix
+++ b/home/profiles/git.nix
@@ -13,18 +13,17 @@ in
     userEmail = "franck@fcuny.net";
 
     signing = {
-      key = "key::${sshPub.ykey-laptop}";
-      signByDefault = false;
+      key = "key::${sshPub.op}";
+      signByDefault = true;
     };
 
     extraConfig = {
       core.whitespace = "trailing-space,space-before-tab";
       color.ui = "true";
 
-      diff.age.textconv = "${pkgs.age}/bin/age --identity ${config.home.homeDirectory}/.age/key.txt --decrypt";
-
       gpg.format = "ssh";
       gpg.ssh.allowedSignersFile = "~/.ssh/allowed_signers";
+      gpg.ssh.program = "/Applications/1Password.app/Contents/MacOS/op-ssh-sign";
 
       # abort if the remote branch does not match the local one
       push.default = "simple";