about summary refs log tree commit diff
path: root/home/git/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-06-18 14:35:30 -0700
committerFranck Cuny <franck@fcuny.net>2022-06-18 14:38:31 -0700
commit4ce9d32c7451bd51767aee301a0d66fa1cf95f41 (patch)
tree343ed8d065f30c7fde6a6e97aab6460d56969ee2 /home/git/default.nix
parentfeat(tools/git-blame-stats): add the tool to nix configuration (diff)
downloadworld-4ce9d32c7451bd51767aee301a0d66fa1cf95f41.tar.gz
feat(tools/git-blame-stats): add the CLI with default git configuration
Change-Id: I59fed38dca010d6aeac48b5066021ca61ba69db9
Reviewed-on: https://cl.fcuny.net/c/world/+/447
Tested-by: CI
Reviewed-by: Franck Cuny <franck@fcuny.net>
Diffstat (limited to 'home/git/default.nix')
-rw-r--r--home/git/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/home/git/default.nix b/home/git/default.nix
index 8043b7b..855d2c2 100644
--- a/home/git/default.nix
+++ b/home/git/default.nix
@@ -1,4 +1,4 @@
-{ lib, config, ... }:
+{ lib, config, pkgs, ... }:
 
 let cfg = config.my.home.git;
 in
@@ -53,5 +53,6 @@ in
       ];
     };
     xdg.dataFile."git/commit.template" = { source = ./commit.template; };
+    home.packages = with pkgs; [ tools.git-blame-stats ];
   };
 }