about summary refs log tree commit diff
path: root/home/emacs/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-09 09:42:03 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-09 09:42:03 -0700
commit1125aaa49aec6a220fd3b9d03076fec398b35a14 (patch)
tree5570b0c094ead9d7879ca3d360ff3de7f45d4516 /home/emacs/default.nix
parentdelete all CLI modules (diff)
downloadworld-1125aaa49aec6a220fd3b9d03076fec398b35a14.tar.gz
add a few more modules to home/ and delete stuff
Diffstat (limited to 'home/emacs/default.nix')
-rw-r--r--home/emacs/default.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/home/emacs/default.nix b/home/emacs/default.nix
index b6c07d3..17b44c5 100644
--- a/home/emacs/default.nix
+++ b/home/emacs/default.nix
@@ -5,10 +5,16 @@ in {
     enable = mkEnableOption "emacs configuration";
   };
 
-  config.home.packages = with pkgs;
-    lib.mkIf cfg.enable ([
+  config.home = lib.mkIf cfg.enable {
+    packages = with pkgs; [
       emacsPgtkGcc
       # see https://github.com/hlissner/doom-emacs/issues/4138
       (aspellWithDicts (dicts: with dicts; [ en en-computers en-science ]))
-    ]);
+    ];
+
+    sessionVariables = {
+      EDITOR = "emacsclient -c -a=";
+      VISUAL = "emacsclient -c -a=";
+    };
+  };
 }