about summary refs log tree commit diff
path: root/flake/mba.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-12-04 07:35:44 -0800
committerFranck Cuny <franck@fcuny.net>2023-12-04 07:35:44 -0800
commit67edd7ba89d98e7534394dab674360da99f40e3d (patch)
tree6575bfbe152b84f94e931d7c95235fcd996a1847 /flake/mba.nix
parentformatting a few files with treefmt (diff)
downloadworld-67edd7ba89d98e7534394dab674360da99f40e3d.tar.gz
update to 23.11 and break down flakes
Update to 23.11 for both nix and home-manager.

Break down the flake in multiple parts (hosts, devshell) so that they
are easier to maintain. The main reason to start this is because `nix
flake check` was failing, the flake was not correct.
Diffstat (limited to 'flake/mba.nix')
-rw-r--r--flake/mba.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flake/mba.nix b/flake/mba.nix
new file mode 100644
index 0000000..60ac876
--- /dev/null
+++ b/flake/mba.nix
@@ -0,0 +1,20 @@
+{ nixpkgs, home-manager, darwin, inputs, ... }:
+
+let
+  default-system = "aarch64-darwin";
+
+  nixpkgsConfig = {
+    config = {
+      allowUnfree = true;
+    };
+  };
+in
+{
+  system = darwin.lib.darwinSystem {
+    system = default-system;
+    modules = [
+      ../hosts/mba
+      home-manager.darwinModules.home-manager
+    ];
+  };
+}