about summary refs log tree commit diff
path: root/flake/devshell.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-12-04 08:10:43 -0800
committerFranck Cuny <franck@fcuny.net>2023-12-04 08:10:43 -0800
commit1285614380a1b5c6261209dd5ca65925438ec441 (patch)
treed7e55ba7736f4f4db0e0ad166ed556aab5c59e37 /flake/devshell.nix
parentadd nixd as a LSP for nix. (diff)
downloadworld-1285614380a1b5c6261209dd5ca65925438ec441.tar.gz
additional cleanup for flakes
Move the host configuration to `flake/hosts.nix` to follow what we did
with `devshell`.
Diffstat (limited to 'flake/devshell.nix')
-rw-r--r--flake/devshell.nix55
1 files changed, 31 insertions, 24 deletions
diff --git a/flake/devshell.nix b/flake/devshell.nix
index f096bfe..7b75417 100644
--- a/flake/devshell.nix
+++ b/flake/devshell.nix
@@ -5,37 +5,44 @@
     inputs.pre-commit-hooks.flakeModule
   ];
 
-  perSystem = { config, pkgs, inputs', ... }: {
-    devShells.default = pkgs.mkShell {
-      name = "dotfiles";
+  perSystem =
+    { config
+    , inputs'
+    , pkgs
+    , ...
+    }: {
+      devshells.default = {
+        name = "world";
 
-      packages = [
-      ];
+        packages = with pkgs; [
+        ];
 
-      TREEFMT_CONFIG_FILE = config.treefmt.build.configFile;
-    };
+        commands = [
+          { package = config.treefmt.build.wrapper; }
+        ];
+      };
 
-    treefmt = {
-      projectRootFile = ".git/config";
+      treefmt = {
+        projectRootFile = ".git/config";
 
-      # list of supported programs
-      # https://github.com/numtide/treefmt-nix
-      programs = {
-        nixpkgs-fmt.enable = true;
-        shfmt.enable = true;
-        yamlfmt.enable = true;
-        taplo.enable = true;
+        # list of supported programs
+        # https://github.com/numtide/treefmt-nix
+        programs = {
+          nixpkgs-fmt.enable = true;
+          shfmt.enable = true;
+          yamlfmt.enable = true;
+          taplo.enable = true;
+        };
       };
-    };
 
-    pre-commit = {
-      settings = {
-        hooks = {
-          # deadnix.enable = true;
-          shellcheck.enable = true;
-          treefmt.enable = true;
+      pre-commit = {
+        settings = {
+          hooks = {
+            # deadnix.enable = true;
+            shellcheck.enable = true;
+            treefmt.enable = true;
+          };
         };
       };
     };
-  };
 }