about summary refs log tree commit diff
path: root/flake/devshell.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-02-23 08:49:10 -0800
committerFranck Cuny <franck@fcuny.net>2024-03-04 08:36:45 -0800
commit0b7a643ec291d8bda1f91db3cc1e436d317e6e1e (patch)
treeb221fcf66319c87ff5173281e52e4b74ed1bba70 /flake/devshell.nix
parentchore: update flake (diff)
downloadworld-0b7a643ec291d8bda1f91db3cc1e436d317e6e1e.tar.gz
nix libraries and modules will be under `nix/`
Diffstat (limited to 'flake/devshell.nix')
-rw-r--r--flake/devshell.nix101
1 files changed, 0 insertions, 101 deletions
diff --git a/flake/devshell.nix b/flake/devshell.nix
deleted file mode 100644
index 79bb2f9..0000000
--- a/flake/devshell.nix
+++ /dev/null
@@ -1,101 +0,0 @@
-{ inputs, ... }: {
-  imports = [
-    inputs.devshell.flakeModule
-    inputs.treefmt-nix.flakeModule
-    inputs.pre-commit-hooks.flakeModule
-  ];
-
-  perSystem =
-    { config
-    , pkgs
-    , ...
-    }: {
-      devshells.default = {
-        name = "world";
-
-        packages = with pkgs; [
-          (config.treefmt.build.wrapper)
-
-          python3
-
-          go_1_21
-          gopls
-          golangci-lint
-          goreleaser
-        ];
-
-        devshell.startup = {
-          pre-commit.text = config.pre-commit.installationScript;
-        };
-
-        commands = [
-          { package = config.treefmt.build.wrapper; }
-          {
-            name = "environment";
-            help = "Print various information from CI";
-            category = "CI";
-            command = "make build-environment";
-          }
-          {
-            name = "update";
-            help = "Update + Commit the Lock File";
-            command = "nix flake update --commit-lock-file";
-            category = "nix";
-          }
-          {
-            name = "build-darwin";
-            category = "darwin";
-            help = "Build the current darwin configuration";
-            command = "darwin-rebuild build --flake .#";
-          }
-          {
-            name = "switch-darwin";
-            category = "darwin";
-            help = "Switch to the current darwin configuration";
-            command = "darwin-rebuild switch --flake .#";
-          }
-          {
-            name = "build-commands";
-            category = "cmd";
-            help = "Build all the commands";
-            command = "make build-binaries";
-          }
-          {
-            name = "clean";
-            category = "cmd";
-            help = "Delete all the artifacts in bin/";
-            command = "make clean";
-          }
-        ];
-      };
-
-      treefmt = {
-        projectRootFile = ".git/config";
-
-        # list of supported programs
-        # https://github.com/numtide/treefmt-nix
-        programs = {
-          gofmt.enable = true;
-          gofumpt.enable = true;
-          nixpkgs-fmt.enable = true;
-          shellcheck.enable = true;
-          shfmt.enable = true;
-          taplo.enable = true;
-          # I don't understand why this is causing issues in CI. When
-          # I run `nix flake check` locally I don't get any issues but
-          # CI is failing with errors in some of the workflows.
-          # Commenting this until I have a proper solution
-          # yamlfmt.enable = true;
-        };
-      };
-
-      pre-commit = {
-        settings = {
-          hooks = {
-            deadnix.enable = true;
-            treefmt.enable = true;
-          };
-        };
-      };
-    };
-}