about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-06-10 13:48:42 -0700
committerFranck Cuny <franck@fcuny.net>2022-06-10 13:56:50 -0700
commitdbc26c72e6c7de7c8737154f47df6da7c760efd3 (patch)
tree7e87286985626ad8028a1854c6835de8cc948259 /flake.nix
parentfix(scripts): no need to create tags when deploying to fly.io (diff)
downloadworld-dbc26c72e6c7de7c8737154f47df6da7c760efd3.tar.gz
ci(default): add `apps.ci.shellcheck` to flake.nix
I can now run `nix run .#ci.shellcheck` to validate the shell scripts
with shellcheck in the repository.

The pipeline in buildKite will need to be updated.

Change-Id: Ia52ede86adfa58c9615b0f9e290ef5d5b8adb303
Reviewed-on: https://cl.fcuny.net/c/world/+/409
Tested-by: CI
Reviewed-by: Franck Cuny <franck@fcuny.net>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index c5be2b6..6f1d036 100644
--- a/flake.nix
+++ b/flake.nix
@@ -42,7 +42,7 @@
       let
         pkgs = import inputs.nixpkgs { inherit system; };
         home-manager = inputs.home-manager.defaultPackage."${system}";
-        ci = import ./ops/ci/fmt.nix { inherit pkgs; };
+        ci = import ./ops/ci { inherit pkgs; };
       in
       {
         packages = pkgs // {
@@ -61,7 +61,10 @@
         };
 
         # `nix run .#ci.format` formats in current directory!
-        apps.ci.format = ci.mkFmtScript self;
+        apps.ci.format = ci.fmt.mkFmtScript self;
+
+        # `nix run .#ci.shellcheck` formats in current directory!
+        apps.ci.shellcheck = ci.shell.mkShellCheckScript self;
 
         devShell = pkgs.mkShell {
           buildInputs = with pkgs; [