about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-06-27 17:39:11 -0700
committerFranck Cuny <franck@fcuny.net>2022-06-28 06:42:41 -0700
commitd902c4a9a1e521c75df5f370b18f75f994890a17 (patch)
treea704ad7d959cbfacd585cde7d33dca8e67105e7e /flake.nix
parentfix(flake): remove duplicated definition of flake-utils (diff)
downloadworld-d902c4a9a1e521c75df5f370b18f75f994890a17.tar.gz
ref(flake): rename utils to futils
This name is more specific (f is for flake in this case).

Change-Id: Iaad98d8325b81cfe1af8b692ef7cd13586f251e6
Reviewed-on: https://cl.fcuny.net/c/world/+/585
Reviewed-by: Franck Cuny <franck@fcuny.net>
Tested-by: CI
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index a249747..709eb5e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -5,7 +5,7 @@
     # Nixpkgs, NixOS's official repo
     nixpkgs.url = "github:nixos/nixpkgs/release-22.05";
 
-    utils.url = "github:numtide/flake-utils";
+    futils.url = "github:numtide/flake-utils";
 
     # We use the unstable nixpkgs repo for some packages.
     nixpkgs-unstable.url = "github:nixos/nixpkgs/nixpkgs-unstable";
@@ -36,7 +36,7 @@
         aptos = lib.mkSystem { hostname = "aptos"; };
         tahoe = lib.mkSystem { hostname = "tahoe"; };
       };
-    } // inputs.utils.lib.eachDefaultSystem (system:
+    } // inputs.futils.lib.eachDefaultSystem (system:
       let
         pkgs = import inputs.nixpkgs { inherit system; };
         home-manager = inputs.home-manager.defaultPackage."${system}";