about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <fcuny@mba-fcuny.localdomain>2023-09-11 16:55:36 -0700
committerFranck Cuny <fcuny@mba-fcuny.localdomain>2023-09-11 16:55:36 -0700
commitc5b1c207532dd29b14d3f1a7b6b25a01a2e4824b (patch)
treea1af5028b5aa4c5944fbbee2af1418f6d704f433 /flake.nix
parentsome changes to GitHub action (diff)
downloadworld-c5b1c207532dd29b14d3f1a7b6b25a01a2e4824b.tar.gz
add configuration for the M2 macbook air
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 9ede1aa..6a2cfa5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -42,6 +42,9 @@
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
+    darwin.url = "github:lnl7/nix-darwin";
+    darwin.inputs.nixpkgs.follows = "nixpkgs";
+
     pre-commit-hooks = {
       type = "github";
       owner = "cachix";
@@ -56,7 +59,7 @@
   };
 
   # Output config, or config for NixOS system
-  outputs = inputs@{ self, ... }:
+  outputs = inputs@{ self, darwin, home-manager, ... }:
     let
       myLib = import ./nix inputs;
       lib = inputs.nixpkgs.lib // builtins;
@@ -158,6 +161,15 @@
         tahoe = myLib.mkSystem { hostname = "tahoe"; };
       };
 
+      darwinConfigurations = {
+        "mba-fcuny" = darwin.lib.darwinSystem {
+          system = "aarch64-darwin";
+          modules = [
+              ./hosts/mba
+          ];
+        };
+      };
+
       homeConfigurations = {
         useGlobalPkgs = true;
         useUserPackages = true;