about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-03 15:12:16 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-03 15:12:16 -0700
commitb72274ab06b4c160fc8d3afe8e2d67863c893a58 (patch)
treeb00c3b128d55d1f51395243902c0dea60fe7df4b /flake.nix
parentRevert "create a new role for navidrome" (diff)
downloadworld-b72274ab06b4c160fc8d3afe8e2d67863c893a58.tar.gz
home-manager: add `isTrusted`
Install and configure some programs only on trusted machines. On trusted
machines, my mails, GPG and a few other things are configured. A machine
where this is not needed on a regular basis to get things done don't
need that much information.

Also rename `desktop/trust` to `trusted`, in case we want these packages
on a host that is not a desktop, and `trusted` is a better description.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index bfa867a..8762c80 100644
--- a/flake.nix
+++ b/flake.nix
@@ -51,12 +51,14 @@
           system = "x86_64-linux";
           hostname = "carmel";
           isDesktop = true;
+          isTrusted = true;
         };
         "fcuny@aptos" = lib.mkHome {
           username = "fcuny";
           system = "x86_64-linux";
           hostname = "aptos";
           isDesktop = true;
+          isTrusted = true;
         };
         "fcuny@tahoe" = lib.mkHome {
           username = "fcuny";