about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-01-07 17:09:25 -0800
committerFranck Cuny <franck@fcuny.net>2023-01-07 17:09:25 -0800
commita8f11a523cca71873fb2847babee2ac468b0c44c (patch)
tree7e9b46661537d03cf9638a47cce7f3d747449a87 /flake.nix
parentfix(home/emacs): don't install nixpkgs-fmt here (diff)
downloadworld-a8f11a523cca71873fb2847babee2ac468b0c44c.tar.gz
ref(flake): use latest version for nixos
Don't pin, just use latest.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 15 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 8633bda..662e6ce 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,7 +2,12 @@
   description = "personal NixOS configurations";
 
   inputs = {
-    nixpkgs.url = "github:nixos/nixpkgs/release-22.11";
+    nixpkgs = {
+      type = "github";
+      owner = "NixOS";
+      repo = "nixpkgs";
+      ref = "nixos-unstable";
+    };
 
     futils.url = "github:numtide/flake-utils";
 
@@ -18,9 +23,14 @@
     nur.url = "github:nix-community/NUR";
 
     home-manager = {
-      url = "github:nix-community/home-manager/release-22.11";
-      # We want home-manager to use the same set of nixpkgs as our system.
-      inputs.nixpkgs.follows = "nixpkgs";
+      type = "github";
+      owner = "nix-community";
+      repo = "home-manager";
+      ref = "master";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        utils.follows = "futils";
+      };
     };
 
     rust = {
@@ -36,6 +46,7 @@
       inputs = {
         flake-utils.follows = "futils";
         nixpkgs.follows = "nixpkgs";
+        nixpkgs-stable.follows = "nixpkgs";
       };
     };