about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-12-04 08:10:43 -0800
committerFranck Cuny <franck@fcuny.net>2023-12-04 08:10:43 -0800
commit1285614380a1b5c6261209dd5ca65925438ec441 (patch)
treed7e55ba7736f4f4db0e0ad166ed556aab5c59e37 /flake.nix
parentadd nixd as a LSP for nix. (diff)
downloadworld-1285614380a1b5c6261209dd5ca65925438ec441.tar.gz
additional cleanup for flakes
Move the host configuration to `flake/hosts.nix` to follow what we did
with `devshell`.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 5 insertions, 19 deletions
diff --git a/flake.nix b/flake.nix
index 8994fc9..93df93c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -32,28 +32,14 @@
   };
 
   # Output config, or config for NixOS system
-  outputs = inputs@{ self, flake-parts, ... }:
-    flake-parts.lib.mkFlake { inherit inputs; } {
-      flake =
-        let
-          mba = import ./flake/mba.nix {
-            inherit (inputs) nixpkgs home-manager darwin;
-            inherit inputs;
-          };
-        in
-        {
-          darwinConfigurations = {
-            mba-fcuny = mba.system;
-          };
-        };
-
-      systems = [
-        "aarch64-darwin"
-        "x86_64-linux"
-      ];
+  outputs = inputs:
+    inputs.flake-parts.lib.mkFlake { inherit inputs; } {
+
+      systems = [ "aarch64-darwin" "x86_64-linux" ];
 
       imports = [
         ./flake/devshell.nix
+        ./flake/hosts.nix
       ];
     };
 }