about summary refs log tree commit diff
path: root/users/fcuny/resume/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/resume/default.nix')
-rw-r--r--users/fcuny/resume/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/users/fcuny/resume/default.nix b/users/fcuny/resume/default.nix
new file mode 100644
index 0000000..86fbcf0
--- /dev/null
+++ b/users/fcuny/resume/default.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }:
+
+pkgs.stdenv.mkDerivation rec {
+  name = "resume";
+
+  src = ./.;
+
+  nativeBuildInputs = [ pkgs.pandoc pkgs.git ];
+
+  installPhase = ''
+    mkdir -p $out
+    pandoc --self-contained --css styles/resume.css --from org --to html --output $out/resume.html resume.org
+  '';
+
+  publish = pkgs.writers.writeBashBin "publish" ''
+    set -ueo pipefail
+    export PATH=${pkgs.lib.makeBinPath [ pkgs.pandoc pkgs.git ]}
+
+    cd $(git rev-parse --show-toplevel)/users/fcuny/resume
+
+    out=$(git rev-parse --show-toplevel)/users/fcuny/blog/static/resume.html
+    pandoc --self-contained --css styles/resume.css --from org --to html --output $out resume.org
+  '';
+
+  meta = with pkgs.lib; {
+    description = "franck cuny's resume";
+    homepage = "https://fcuny.net/resume.html";
+    license = licenses.mit;
+    platforms = platforms.linux;
+    maintainers = [ ];
+  };
+}