about summary refs log tree commit diff
path: root/users/fcuny/notes/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/notes/default.nix')
-rw-r--r--users/fcuny/notes/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/users/fcuny/notes/default.nix b/users/fcuny/notes/default.nix
new file mode 100644
index 0000000..ee9ebb9
--- /dev/null
+++ b/users/fcuny/notes/default.nix
@@ -0,0 +1,30 @@
+{ pkgs, ... }:
+
+pkgs.stdenv.mkDerivation rec {
+  name = "notes.fcuny.net";
+
+  src = ./.;
+
+  nativeBuildInputs = [ pkgs.hugo pkgs.git ];
+
+  installPhase = ''
+    mkdir -p $out
+    ${pkgs.hugo}/bin/hugo --minify -d $out/
+  '';
+
+  server = pkgs.writers.writeBashBin "run-server" ''
+    set -ueo pipefail
+    cd $(git rev-parse --show-toplevel)
+    cd users/fcuny/notes
+    export PATH=${pkgs.lib.makeBinPath [ pkgs.hugo pkgs.git ]}
+    hugo server -D
+  '';
+
+  meta = with pkgs.lib; {
+    description = "franck cuny's notes";
+    homepage = "https://notes.fcuny.net";
+    license = licenses.mit;
+    platforms = platforms.linux;
+    maintainers = [ ];
+  };
+}