about summary refs log tree commit diff
path: root/users/fcuny/git.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/fcuny/git.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/users/fcuny/git.nix b/users/fcuny/git.nix
new file mode 100644
index 0000000..adaf626
--- /dev/null
+++ b/users/fcuny/git.nix
@@ -0,0 +1,20 @@
+{
+  programs.git = {
+    enable = true;
+    aliases = {
+      s = "status --short --branch";
+      amend = "commit --amend --no-edit";
+    };
+    extraConfig = {
+      core.whitespace = "trailing-space,space-before-tab";
+      color.ui = "true";
+      push.default = "simple";
+      init.defaultBranch = "main";
+      branch.autosetuprebase = "remote";
+      branch.sort = "authordate";
+    };
+    userName = "Franck Cuny";
+    userEmail = "franck@fcuny.net";
+    ignores = [ "*.o" "*.pyc" "*.pyo" "*.elc" "*~" ".direnv/*" "\\#*\\#" ".\\#" ];
+  };
+}