about summary refs log tree commit diff
path: root/users/fcuny/devel/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/fcuny/devel/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/users/fcuny/devel/default.nix b/users/fcuny/devel/default.nix
index 2c03c74..b4ff02e 100644
--- a/users/fcuny/devel/default.nix
+++ b/users/fcuny/devel/default.nix
@@ -1,7 +1,9 @@
-{ config, lib, pkgs, ... }:
+{ config, lib, pkgs, isDesktop, ... }:
+with lib;
 
 {
   imports = [ ./go.nix ./python.nix ];
 
-  home.packages = with pkgs; [ flyctl hugo rnix-lsp nixfmt util-linux ];
+  home.packages = with pkgs;
+    [ util-linux ] ++ (optionals isDesktop [ flyctl hugo rnix-lsp nixfmt ]);
 }