about summary refs log tree commit diff
path: root/users/fcuny/desktop/trust/pass.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/desktop/trust/pass.nix')
-rw-r--r--users/fcuny/desktop/trust/pass.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/users/fcuny/desktop/trust/pass.nix b/users/fcuny/desktop/trust/pass.nix
index 6ed346c..a552318 100644
--- a/users/fcuny/desktop/trust/pass.nix
+++ b/users/fcuny/desktop/trust/pass.nix
@@ -11,6 +11,23 @@
     };
   };
 
+  programs.git = {
+    signing = {
+      key = config.programs.gpg.settings.default-key;
+      signByDefault = true;
+    };
+    extraConfig = {
+      credential = {
+        helper = "${pkgs.gitAndTools.pass-git-helper}/bin/pass-git-helper";
+        useHttpPath = true;
+      };
+    };
+  };
+
+  xdg.configFile."pass-git-helper/git-pass-mapping.ini" = {
+    source = ./git-pass-mapping.ini;
+  };
+
   services.password-store-sync.enable = true;
 
   # Ensure the password store things are in the systemd session