about summary refs log tree commit diff
path: root/users/fcuny/desktop/sway/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/desktop/sway/default.nix')
-rw-r--r--users/fcuny/desktop/sway/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/users/fcuny/desktop/sway/default.nix b/users/fcuny/desktop/sway/default.nix
new file mode 100644
index 0000000..d4d9093
--- /dev/null
+++ b/users/fcuny/desktop/sway/default.nix
@@ -0,0 +1,39 @@
+{ config, lib, pkgs, ... }:
+
+{
+  imorts = [
+    ./wofi.nix
+  ];
+
+  home.packages = [
+    pkgs.pavucontrol
+    pkgs.wofi
+    pkgs.wl-clipboard
+    pkgs.wf-recorder
+  ];
+
+  home.sessionVariables = {
+    MOZ_ENABLE_WAYLAND = true;
+    LIBSEAT_BACKEND = "logind";
+  };
+
+  wayland.windowManager.sway = {
+    enable = true;
+    systemdIntegration = true;
+    config = rec {
+      modifier = "Mod4";
+      terminal = "${config.programs.alacritty.package}/bin/alacritty";
+      menu = "${pkgs.wofi}/bin/wofi -S run";
+      defaultWorkspace = "workspace number 1";
+      startup = [
+        # Initial lock
+        { command = "${pkgs.swaylock-effects}/bin/swaylock"; }
+        # Start idle daemon
+        { command = "${pkgs.swayidle}/bin/swayidle -w"; }
+        # Start waybar
+        { command = "${pkgs.waybar}/bin/waybar"; }
+      ];
+      bars = [ ];
+    };
+  };
+}